Swoop
12 days ago
Technical Support

Having an issue where I seem to not be routing correctly in the Firestorm mode of Battlefield 5 only. It's fine with normal modes where from Australia to Singapore I get 65 ping, but try to play Firestorm mode I get 220 ping to Singapore servers. I only get that sort of ping when I don't run Mud Fish, but it is running because I check or join normal modes and it's fine. My other friends in Australia who use Mud Fish are experiencing a similar issue. This has only started occurring in the last couple of days. I have been on the latest version, but also tried rolling back to 4.5.1 with no result. I've logged in, logged out, reinstalled, tried full VPN and everything I could think of, but nothing fixes this issue. The fact that it works fine with normal Battlefield 5 modes means that Mud Fish is working fine except has some problem with Firestorm all of the sudden. Please help me sort this issue. Good ping to Firestorm servers is why I pay for Mud Fish. Thanks.